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With SAP Crystal Reports 2020

SAP Crystal Reports’ core capability surrounds database reporting – connecting to any of a wide variety of
databases and data sources and making sense of the underlying data. While Crystal Reports’ capabilities are
very sophisticated and, often, limited by your design imagination, there are several fundamental data
handling features virtually every report, whether simple or complex, will make use of:
• Record Selection / Filtering
• Sorting Data
• Grouping and Summarizing
You’ll use variations of these techniques almost immediately upon creating any new report or making
significant modifications to an existing report.
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RECORD SELECTION / FILTERING
Newer database systems are collecting and storing increasingly larger sets of data. It’s not uncommon for
current “big data” systems to contain millions, if not billions, of data records. When you connect SAP Crystal
Reports to these systems, one of the first considerations you’ll make is how to narrow down, or select, the
limited set of data that is relevant to your current reporting need. It’s a very rare report that needs to include
all the data in the data source.
While some toolsets refer to this process as “filtering,” SAP Crystal Reports refers to record selection.
The Select Expert simplifies this process with just a few mouse clicks. After connecting to your data source
(and, very possibly, before initially previewing the report), display the Select Expert with the Report -> Select
Expert -> Record dropdown menu option. You may also click the Select Expert toolbar button
and
choose Record from the dropdown list. If the report currently contains no record selection at all, the Choose
Field dialog box will appear. Select the initial data field you want to use to select a subset of records. The
Select Expert – Record dialog box will appear with a tab added for the selected field.
Click the first dropdown list below the tab and select a comparison operation (such as equal to, not equal to,
greater than, and so forth) to use with the chosen database field.

You may then type in a comparison value in the right text field. You may also click the dropdown arrow to query
the data source and present a list of possible values from the field in the data source (depending on the size of the
data source, the list may take some time to populate and may not contain all available values from the data
source). Then, scroll through the list and select the value to compare.
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Often, you will want to make use of more than one field in record selection. If so, click the <New> tab in the
Select Expert. The Choose Field dialog box will reappear where you may select another field to add to the
Select Expert. As before, a tab for the newly chosen field will appear. Select the desired comparison operation
and type in or select comparison values to the right.

When finished, click OK. You may be presented with a dialog box indicating that the record selection formula
has changed. You are prompted to Use Saved Data or Refresh Data. If the new record selection has been
widened (that is, changed to encompass more data than the previous selection), you’ll probably want to
Refresh Data to query the data source with the updated selection and retrieve additional data. If you’ve
narrowed (that is, changed to further reduce the amount of data), you may prefer to Use Saved Data to apply
the new selection to the existing set of data that has been cached by the current report.

Using saved data will typically be faster (sometimes, substantially so) than refreshing data. However, if record
selection has been widened, saved data will probably not provide a correct set of data meeting all selection
criteria. Refreshing data will always retrieve the most current set of data meeting the most recent selection
criteria, but may exhibit slow performance in the process.
NOTE: Using the Select Expert actually creates a full Crystal Reports formula, known as the Record Selection
Formula. If you are familiar with the Crystal Reports formula language, you may view or modify this formula
by clicking the
button in the Select Expert, or from the Report -> Selection Formulas -> Record
dropdown menu option.
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SORTING DATA
When you initially create a report, individual data records from the data source each appear in a report
Details section. The order in which records appear on the report isn’t always predictable, and is based on how
the underlying database or data source driver return data. For example, the data source may return records
in the order they were entered, or ordered by a key field or unique identifier.
To predictably order (or sort) report data, click the Record Sort Expert toolbar button
, or choose
Report -> Record Sort Expert from the dropdown menus. The Record Sort Expert dialog box will appear.
Select the first (or only) field you wish to sort the report by and click > to move it to the Sort Fields list on the
right. Then, select either the Ascending or Descending radio buttons to choose the sort direction (Ascending
being in A – Z/0 – 9 order, Descending being in Z – A/9 – 0 order). You are free to set multiple levels of sorting
by selecting and adding additional fields to the Sort Fields list and selecting the desired sort order. If, for
example, you wish to sort a report in A – Z order by customer name, and within multiple records of the same
customer name, sort in newest-to-oldest order by date, you would sort first by Customer Name in ascending
order, and then by Order Date in descending order.

CAUTION: Sorting reorders the appearance of Crystal Reports Details sections, where individual data records
are displayed. If you have designed a summary report by hiding or suppressing the Details section (as
discussed later in this white paper), sorting won’t have any effect. You can confirm by looking in the Preview
tab for small D section names. Sorting will only affect those sections.
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GROUPING AND SUMMARIZING
While sorting may be sufficient for simple listing-style reports, more sophisticated reporting will benefit from
an enhanced technique to group similar records together. Grouping data (sometimes referred to as setting a
“level break”), will not only sort the report by the selected field, but will create an additional report section at
the beginning and end of each group of report records. This permits summaries and subtotals to be placed at
the beginning or ending of each report group to, for example, analyze the number of orders and total order
amount for each customer.
To group the report, click the Insert Group toolbar button
, or select Insert -> Group from the
dropdown menus. The Insert Group dialog box will appear. This dialog box contains two tabs: Common and
Options.
On the Common tab, select the field you wish to group by from the first dropdown list. In the second
dropdown list, choose the order in which you want groups to appear:
• Ascending : Groups appear in A-Z / 0-9 order
• Descending : Groups appear in Z-A / 9-0 order
• Specified : The dialog box expands to permit you to create one or more named groups, whereby you specify
combinations of values to combine into a custom group.
• Original : Groups appear based on the original order data is returned from the data source. This is a limiteduse option only useful for special situations when data is returned from the data source in a predictable,
consistent manner.
If you wish to customize the way the report is grouped, you may check Use a Formula as Group Sort Order,
click the formula button, and type in a Crystal Reports formula to control report grouping.

On the Options tab, make optional choices to further customize the way Crystal Reports groups the report.
• Customize Group Name Field places a value other than the field the group is based on in the group header
section. Select the desired radio button:
o Choose Existing Field to pick an alternative field to display in the group header. This option is
helpful, for example, if you wish to group on a unique customer ID to avoid different customers with
the same name from being grouped together, but still display the customer name instead of the
customer ID at the beginning of each group.
o Use a Formula as Group Name to add a custom Crystal Reports formula to display at the
beginning of each group.
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• Keep Group Together : Attempts to include all records in a group together on a page without inserting a
page break. This often results in white space at the bottom of pages because Crystal Reports will advance to
the next page to start a new group. If a group is larger than a single page, a page break will still occur.
• New Page After : Type in a number (or, add a conditional Crystal Reports formula to return a custom
number) to determine how many groups can print on a single page before a forced page break occurs. This
permits a page break to be inserted after a specified number of smaller groups all are included on the same
page.
• Repeat Group Header On Each Page : When larger groups span multiple pages, this option repeats the
group header section (the section that appears at the beginning of a group) at the top of each subsequent
page a group spans.

Once you’ve created a new group, Crystal Reports will add two new report sections:
• Group Header : This section appears at the beginning of each group. By default, Crystal Reports adds a
Group Name field to the group header, which displays the name of the current group. For example, if you
create a group based on Customer Name, the Group Header will appear at the beginning of each customer
group and will display the name of the customer via the Group Name Field.
• Group Footer: This section appears at the end of each group. By default, the Group Footer is initially blank.
Typically, you will add subtotal and summary fields and text objects to the group footer.
Details sections that encompass individual data records within each group appear between the group header
and group footer.
TIP: You are not limited to creating just one report group. Often, your report will benefit from nesting groups –
creating multiple groups within each other that create a logical hierarchy (for example, grouping by Sales
Person within Sales Region within State). You may simply use the Insert Group options subsequent times to
create additional groups. When you do this, group header and footer sections will denote the order in which
groups were created. The first group header will be labeled “Group Header #1,” the second “Group Header
#2,” and so forth.
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INSERTING SUBTOTALS AND SUMMARIES
Depending on the specific requirements of your report, you may choose to simply create report groups and
leave the default group header and footer sections as-is. However, you’ll most often want to add subtotal or
summary values, as well as descriptive text objects at the beginning or ending of each group.

Once you’ve created desired groups, click the Insert Summary toolbar button
, or choose Insert ->
Summary from the dropdown menus. The Insert Summary dialog box will appear. Select the field you wish to
total or summarize from the Choose the field to summarize dropdown list. Select the desired type of subtotal
or summary from the Calculate the summary dropdown list (noting that the data type of the selected field
will limit the available type of summary – for example, non-numeric fields will not have a Sum option
available, but will have other applicable options, such as Count).
Select where you wish to add the subtotal or summary from the Summary location dropdown list (available
location options will vary depending on how many groups you have created on the report). Checking Add to
all group levels will add the new summary to all group footers, as well as the report footer, without the need
to use the Insert Summary option multiple times. Checking Show as a percentage of, and selecting the
desired “higher-level” total (more than one option will appear here if you created multiple groups), will
create a total that appears as a percentage of the higher-level number, rather than an actual summary or
subtotal.

When you click OK, the summary field will be added to the specified group or report footer sections. You may
move the resulting summary field elsewhere in the section and format it as needed. You may also add text
objects (or other fields) to the section to annotate and augment the summaries and subtotals.
TIP: Because subtotal and summary fields are not specifically “tied” to the report section they are originally
added to, you may move or copy summary fields to any other group or report header or footer. They will
automatically adjust to the section they are placed in, showing the correct summary value for that group or
report level.
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CREATING A SUMMARY REPORT BY HIDING SECTIONS
By default, Details sections (that display individual data records) will continue to appear on the report after
you create groups and add summaries. These types of reports are often referred to as detail reports because
all individual record detail is visible. However, you may wish to only analyze the summary information for
each group, rather than seeing all the underlying detail. These summary reports are more concise, only
presenting the group names and summary/subtotal fields, rather than all the underlying detail. Summary
reports are created by simply hiding or suppressing the report Details section so that only group header and
footer sections appear.
If the Design tab is displayed, RIGHT-CLICK on the blue Details section name at the left of the design canvas. If
you are previewing the report, RIGHT-CLICK on any of the D blue section names at the left. In both cases, a
context menu will appear. Select either Hide (Drill-Down OK) or Suppress (No-Drill Down) to suppress display
of the details section.

Only group headers and footers will now appear on the report, presenting a much more concise summary
report. If you later choose to display all the underlying detail, return to the Design tab, RIGHT-CLICK on the
Details section, and select either the Show or Don’t Suppress option.

TIP: Powerful interactive drill-down reports can be created by use of multiple report groups, summaries, and
hidden sections. Other white papers on www.crystalreports.com/guides explore detailed drill-down reporting
techniques.
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express permission of SAP AG or an SAP affiliate company.
SAP and other SAP products and services mentioned herein as well as their respective logos are
trademarks or registered trademarks of SAP AG (or an SAP affiliate company) in Germany and other
countries. Please see https://www.sap.com/about/legal/trademark.html for additional trademark
information and notices. Some software products marketed by SAP AG and its distributors contain
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National product specifications may vary.
These materials are provided by SAP AG or an SAP affiliate company for informational purposes only,
without representation or warranty of any kind, and SAP AG or its affiliated companies shall not be liable for
errors or omissions with respect to the materials. The only warranties for SAP AG or SAP affiliate company
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products and services, if any. Nothing herein should be construed as constituting an additional warranty.
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outlined in this document or any related presentation, or to develop or release any functionality mentioned
therein. This document, or any related presentation, and SAP AG’s or its affiliated companies’ strategy
and possible future developments, products, and/or platform directions and functionality are all subject
to change and may be changed by SAP AG or its affiliated companies at any time for any reason without
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