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1 Where Can This Script Be Used?
This demo script has been written for usage with the SAP S/4HANA 1809 FPS01 & FPS02 Fully-Activated Appliance (in short
“appliance” in this script), hence you will need such an appliance to make use of this guide.
The appliance can be brought up in two ways, and the demo scenario in this script is largely the same for both:
1.

Via SAP Cloud Appliance Library (hosted on cloud providers)
You need a cloud provider account at AWS, MS Azure, or GCP. With this, you can deploy the appliance within 1-2 hours from
https://cal.sap.com > Solutions > SAP S/4HANA 1809 FPS01 & FPS02 Fully-Activated Appliance.

2.

Via installing it on your own on-premise hardware.
You need to provide your own hardware, and order & install the appliance as explained in SAP Note 2041140.

If you are new to the SAP S/4HANA Fully-Activated Appliance, introductory information can be found here:
https://blogs.sap.com/2018/12/12/sap-s4hana-fully-activated-appliance-create-your-sap-s4hana-1809-system-in-a-fraction-ofthe-usual-setup-time/

Important:
Before you start your demo, please read SAP S/4HANA Fully-Activated Appliance: Demo Scripts for information about necessary
preparations, especially any post-deployment steps to ensure the full functionality of your appliance.
Besides this, you will also find links to all demo scripts on this page.
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2 Demo Story: SAP Screen Personas
2.1

Background

The purpose of this section is to describe the best practices for general configuration steps required to create a flavor in SAP
Screen Personas 3.0.
The goal of SAP Screen Personas is to allows you to personalize SAP screens, automate business processes, and run them on your
phone, tablet, or desktop. It provides a simple drag and drop approach to modify most SAP GUI screens to improve usability and
visual appeal. Standard documentation for development activities for SAP Screen Personas is available in the SAP Help Portal.
Preliminary Steps
Before you start developing a flavor there are a number of preliminary steps that you should progress through to determine user
requirements and design a user interface that meets these requirements:
•

Get familiar with the application or transaction, referencing for example, an SAP Best Practices process flow as a basis.

•

Consult with a business user of the transaction or application and determine their requirements.

•

Consult with a UI/UIX Designer to make design decisions for the flavor.

•

Determination of needed/required screen elements for processing like:
-

Buttons

-

Input/output fields

-

Descriptions

-

Data fields

-

Tables

-

Tabs

-

Others

•

Determination of unused, not needed and disabled screen elements

•

Grouping screen element to be displayed by theme or functionality

•

Get familiar with UI design guidelines and company branding rules

Once you have gone through these preparatory steps, you can start developing the flavor using SAP Screen Personas.

2.2

Creating a Flavor

What to Do

What You Will See

Access the SAP GUI:
Client: 100
User: S4H_PERS
Password: Welcome1

Choose URL—Personas.
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What to Do

What You Will See

In your browser, logon
again:
Client: 100
User: S4H_PERS
Password: Welcome1

You can create a flavor for
any SAP Transaction code
such as VA01 – Create.
Navigate to VA01 by
choosing SAP Menu →
Logistics → Sales and
Distribution → Sales →
Order → VA01 - Create

Choose SAP Screen
Personas to open the
Flavor Manager (see note
below).

Note: The

SAP
Screen Personas button is
visible after rolling over the
blue header line at the top
of the screen. The button
will appear in the center at
the top of the browser
window. It is displayed as
an icon with the SAP
Screen Personas logo:
The icon has the tooltip
SAP Screen Personas.

Choose Create New Flavor
to create your own flavor.
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What to Do

What You Will See

In the Create New Flavor
dialog box, make the
following entries and
choose Create:
Name: <flavor name>
Description: <your
description>

In the Edit area, doubleclick the Order Type field.
In the One-line Text Field
dialog box, make the
following entry and choose
Done:
Data: OR

Due to time-out issues with
the browser session, we
recommend adopting a
“Save early and save often”
approach.

Note:
Do not wait until you have
completely edited the
flavor before saving the
flavor.
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What to Do

What You Will See

All possible actions or
changeable attributes are
enabled in Screen
Personas menu bar.
For example, you can do
the following for the
selected element:
•

Hide items

•

Drag and drop an item
to a different screen
area

•

Add custom text to a
button by double
clicking into to the
button and enter the
new button text.

•

Resize the screen
element by stretching
the frame or entering
values into the
positioning field of the
menu bar

•

Change Font attributes
for labels and fields

Choose the Insert tab to
insert additional screen
elements to the flavor:
•

Labels

•

Group Boxes

•

Images

•

Buttons

•

Boxes

•

Fields

Note:
You can use a Group Box
to optically arrange screen
elements. To do this,
create a Group Box and
place the screen elements
into this Group Box.

In the Tables tab, these
actions are available:
•

Hiding

•

Moving

•

Changing header text
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What to Do

What You Will See

In the Release tab, these
actions are available:
•

Changing the flavor
name

•

Changing the flavor
description

•

Displaying the history

•

Creating a new
version of the flavor

Choose Save.

The SAP GUI screen
elements that should not
be displayed can be set
invisible using the hide
functionality.
You can do this in edit
mode in the Home tab
using the Hide command.

If you no longer need the
Screen Personas you have
created, you can delete in
edit mode in the choose
the Toolbox dropdown
Insert tab using the Delete
Objects command.

2.3 Sharing a Flavor
Purpose
Once you have created a flavor, this flavor is available for you to edit and execute. To allow other users to either edit or execute the
flavor, you must share the flavor with the user or assign the flavor to a role to which the user is assigned.

Recommendation: To allow another user to edit a flavor, it is recommended that you share the flavor directly with the user.
Procedure
What to Do

What You Will See

Access the SAP GUI:
Client: 100
User: S4H_PERS
Password: Welcome1
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What to Do

What You Will See

Choose
/PERSONAS/FLAVOR
S – Flavor
Maintenance.

Choose the radio
button for the Name
field and enter the
<flavor name>.
Choose Search.

Note:
You can search by ID
or Owner as well.
Choose Change.
In the Assignments tab,
choose the Add User
button.
Enter the User name
and choose the
Assigned checkbox.

Choose Save.

You have shared the flavor with another user. The user can execute the flavor, and if they have
the authorization to edit flavors, can also edit the flavor.

2.4 Copying a Flavor
What to Do

What You Will See

Access the SAP GUI:
Client: 100
User: S4H_PERS
Password: Welcome1
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What to Do

What You Will See

Sometimes it may be necessary to make a copy of a flavor because you want to try something, or you want to have a setup point or
fall back when developing the flavor further on.
There are two options to do this:
1.

Using the browser
The following steps create a copy of a flavor:
•
Select the flavor to be copy,
•
Choose Create New Flavor on Screen Personas Menu bar
•
In the input field Name, enter <flavor name>.
•
In the input field Description, enter <description text>.
•
Check base on flavor <source flavor name> checkbox and choose Create.

What to Do

What You Will See

Access the SAP GUI:
Client: 100
User: S4H_PERS
Password: Welcome1

Choose
/PERSONAS/FLAVOR
S – Flavor
Maintenance.

Choose the radio
button for the Name
field and enter the
<flavor name>.
Choose Search.

Note:
You can search by ID
or Owner as well.
Choose Copy.
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What to Do

What You Will See

You can change the
name and description
to your liking.

We recommend using the second option, to ensure that a consistent copy/version of the flavor is created.

2.5 Changing a Flavor
Procedure
What to Do

What You Will See

Log on to the
development system
using a web browser.
Start the transaction
for which you want to
change a flavor.
Choose the SAP
Screen Personas
button to open the
flavor manager.
Choose the flavor you
want to edit and
choose the Edit Flavor
button.

Note:
You can edit any flavor
to which you are
assigned, not just
those that you created.
Likewise, any user who
has Personas editor
authorizations and has
the flavor assigned to
them can edit a flavor
that you have created.
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2.6 Deleting a Flavor
Procedure
What to Do

What You Will See

Log on to the
development system
using a web browser.
Start the transaction
for which you want to
change a flavor.
Choose the SAP
Screen Personas
button to open the
flavor manager.
Choose the flavor you
want to edit and
choose the Delete
Flavor button.
In the dialog box,
choose Yes.

Results
You have deleted a flavor so that this is no longer displayed in the flavor bar. The flavor can no longer be chosen to be edited or
executed.

Note: The flavor has not been deleted in the backend system. Instead, a deletion flag has been set for the flavor and this action can
be reversed. To irretrievably remove the flavor from the backend system, the system administrator must complete the activity to
permanently delete the flavor. For further guidance on this, refer to Permanently Delete Flavors, Resources, or Themes in the
configuration guide Administration Guide for SAP Screen Personas (building block UPG).

2.7 Working with Resources
Purpose
A resource refers to an object that is uploaded to the Mime repository of the system for use in SAP Screen Personas, for example,
images uploaded as .jpg or .png files. You can upload the image in the Personas editor tool

2.7.1.1

Uploading an Image

Procedure
1.

Place your cursor on the area of the screen where you wish to add an image.

2.

Choose Insert → Image.

3.

In the Insert Image from Image Gallery dialog box, choose Upload Image.

4.

In the Upload Image from File dialog box, select Choose Files.

5.

Choose the file that you want to upload from your local drive or server.

6.

In the Upload Image from File dialog box, choose Upload Image.

Results
You have uploaded an image and can use this in your flavors, for example as a background picture.
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2.7.1.2

Sharing Resources with Other Personas Developers

Use
When you upload an image, this is only available for you to include in a flavor, unless you make this resource public. If the image is
not made public, the image is visible to all end users who use the flavor that you have developed, but it does not appear in the list of
images to use for other developers when they insert images into flavors that they are developing. This may result in one image
being uploaded several times by different developers.
Procedure
1.

Logon to the system using SAP Logon.

2.

Access the transaction using the following navigation path:
Transaction Code

/PERSONAS/RESOURCES

3.

Enter your search criteria for the required flavors in the options in the SAP Screen Personas Resource Maintenance screen; for
example, in the selection field Resource Owner enter your user name.

4.

Choose Search.

5.

In the SAP Screen Personas Resource Maintenance – Mass Maintenance screen, select a resource.

6.

Choose Open.

7.

In the SAP Screen Personas Resource Maintenance – Display “<resource name>” screen, choose Change.

8.

In the Resource section, select Public.

9.

Choose Save.

Results
You have shared the resource with all other developers in this system, and they can use the image when creating their own flavors.

2.8 Appendix
2.8.1.1

Additional Resources

When you are working with SAP Screen Personas, you may find the following resources helpful for you:
•

SAP Community Network SAP Screen Personas
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