How-To Guide: Document Management System (DMS) Setup and Configuration

Applies to:
MDG EAM Solutions by Utopia

Summary
This guide is used to Setup and Configure Document Management System (DMS) and for Document Info Record (DIR) number range configuration and replication of DIR.

Author: Avin Pais
Company: Utopia Global, Inc.
Created On: September 11, 2018
Version: 1.0
# Table of Contents

Introduction ....................................................................................................................................... 3
Prerequisites ..................................................................................................................................... 3
Setup Document Management System .............................................................................................. 3
DMS Configuration for EAM ............................................................................................................... 3
Create Content Repository ............................................................................................................. 4
Maintain Category .......................................................................................................................... 4
Assign Content Repository to Category .......................................................................................... 4
Define Document Types ................................................................................................................. 5
Define Object Links ........................................................................................................................ 5
Define Profile ................................................................................................................................... 6
DMS Activation for Task List .............................................................................................................. 6
DMS Replication for EAM .................................................................................................................. 8
Number Ranges for Documents ........................................................................................................ 8
Defining Number Ranges for Documents .......................................................................................... 9
Assigning Number Ranges to Document types ............................................................................. 10
Clear the Number Range Buffers ................................................................................................. 10
Steps to Replicate Document Info Record for an Object ................................................................. 10
ALE Setup ................................................................................................................................... 11
Create Document Info Record ....................................................................................................... 11
Assigning Document Info Record to Equipment .......................................................................... 11
Replication of Document Info Records with Document Links ......................................................... 14
Enable URL using Generic Object Services ..................................................................................... 15
Prerequisites ................................................................................................................................ 15
Brief Overview ............................................................................................................................. 15
Configuration ............................................................................................................................... 16
Sample Implementation................................................................................................................ 16
Troubleshooting ........................................................................................................................... 16
Introduction

This document describes how to Setup and Configure Document Management System (DMS) and for Document Info Record (DIR) number range configuration and replication of DIR for EAM.

Prerequisites

Document Management System (DMS) is installed.

Setup Document Management System

Refer the attached SAP document for Configuration and Setup of Easy Document Management System.

223_BB_ConfigGuid_e_EN_IN.doc

Note: Contact BASIS team for performing activities in the above attached document.

DMS Configuration for EAM

Use the following steps to configure DMS for EAM

- Create Content Repository
- Maintain Category
- Assign Content Repository to Category
- Define Document Types
- Define Object Links
- Define Profile
Create Content Repository

Create content repository using t-code OAC0.

Maintain Category

Maintain Category using t-code OACT.

Assign Content Repository to Category

Assign content repository to new category as shown in the following screen.
Define Document Types

Use the navigation to define Document types: Cross-Application Components > Document Management > Control Data > Define Document Types.

Note: The configurations are available for Equipment, Functional Location, Measuring Point, Bill of Materials and Object Links except for Task List.

Define Object Links

Define Object Links as shown in the following screen:
**Note:** The above configuration is displayed by default and works for all Objects (i.e., Equipment, Functional Location, Measuring Point, Bill of Materials and Object Links) except for Task List. The relevant objects have the DMS create and attach functionality based on the following settings as detailed in the next steps.

### Define Profile

The profile helps user to determine application and default storage category automatically to make sure that the document is stored in the secured predetermined storage space.

Define Profile as shown in the following screen:

![Define Profile](image1)

**Note:** The system displays the storage category based on the available role access.

Select Profile Key and Set Determination of Definitions of System.

![Select Profile](image2)

### DMS Activation for Task List

In addition to the above steps, the following configuration steps are required to accomplish documents attachments for Task List (i.e., General, Equipment and Functional Location Task Lists) at Header and Operation level.

**Note:** For complete reference of this activation, refer OSS Note: 1821916: IMG activity "Activate Functions for Enterprise Asset Management for further details.

Use the following steps to activate DMS for Task List.

1. Navigate to Plant Maintenance and Customer Service > System Enhancements and Data Transfer > Activate Functions for Enterprise Asset Management and enable the "Active" checkbox.
2. Navigate to Cross applications > Document Management > Control Data > Maintain Key Fields and add the entries as displayed in the following table for Maintenance View for Screens to DMS Object Links.

<table>
<thead>
<tr>
<th>Table</th>
<th>Transaction Code</th>
<th>Field Name</th>
<th>SET/GET Parameter ID</th>
<th>Field Name</th>
<th>SET/GET Parameter ID</th>
<th>Field Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>PMAFVC</td>
<td>IW33</td>
<td>AUFN</td>
<td>ANR</td>
<td>VORNR</td>
<td>LTXA1</td>
<td></td>
</tr>
<tr>
<td>PMAUFK</td>
<td>IW33</td>
<td>AUFR</td>
<td>ANR</td>
<td>KTEXT</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PMPLKO</td>
<td>IA09</td>
<td>PLNTY</td>
<td>PTY</td>
<td>PLNAL</td>
<td>PAL</td>
<td>KTEXT</td>
</tr>
<tr>
<td>PMPLPO</td>
<td>IA07</td>
<td>PLNTY</td>
<td>PTY</td>
<td>PLNK</td>
<td>LTXA1</td>
<td></td>
</tr>
</tbody>
</table>

The following screen is displayed with the entries.

3. Navigate to Cross applications > Document Management > Control Data > Maintain Key Fields to maintain the key fields as highlighted in the following screen.

5. For each Document Type that has been added, select the specific Document Type and add the corresponding configurations for the document types. A sample screen is displayed.

DMS Replication for EAM

If you want to replicate document links into other target systems, you will need to distribute the documents and document links manually. There is no integration of ALE message types DOCMAS and DOLMAS into the Data Replication Framework.

Number Ranges for Documents

To replicate the documents and document links from M.
DG HUB to operational ECC systems, number ranges in operational ECC should be defined as external number range.

Use the following steps for validating and updating the number ranges and assigning the number ranges to the document type.

- **Defining Number Ranges for Documents**
- **Assigning Number Ranges to Document types**
- **Clear the Number Range Buffers**

### Defining Number Ranges for Documents

**IMG Path:**

Cross-Application Components > Document Management > Control Data > Define Number Ranges for Document Numbers

Or,

Can be accessed directly using t-code SNRO with Number Range Object DOKUMENT

Number ranges should be checked in MDG HUB and operational ECC systems.

To use the number range as internal in MDG HUB and external in operational ECC, you can use any of the following methods:

- With existing internal: In Operational ECC, if an existing internal number need to be changed to external number, first set the NR status to ‘0’ and then set the flag for external number. You then need to adjust the external range to the internal range of the source system. Additional internal ranges are optional.
- Set internal number range to current NR status and have external number range start from next number: Set the “to number” to the current status. The external number range may start from next number. If there are multiple number ranges, you may also need multiple external number ranges to avoid overlap.
• With new interval: Create a new interval in both systems. Make the new interval as Internal in HUB and external in Operational ECC. Assign the newly created interval to the document type using the below Section Assigning number ranges to document types.
• In operational ECC combine all internal number ranges in one external Interval. Add internal if required for local creation.

Assigning Number Ranges to Document types

IMG Path
Cross-Application Components > Document Management > Control Data > Define Document Types

Double-Click on the document type. For example: DRW

![Document Type Screenshot]

Clear the Number Range Buffers

To clear the number range buffers in the target system, you can use the report NK_REORGANIZE.

Steps to Replicate Document Info Record for an Object

Note: Equipment Master is taken as a sample object.

Use the following steps to replicate document info record for Equipment Master:

• ALE Setup
• Create Document Info Record
• Assigning Document Info Record to Equipment
• Replication of Document Info Records with Document Links
ALE Setup

Use the following steps for ALE Setup:

1. Create distribution model using t-code BD64.
2. Add the following message types:
   - /UGI3/EQUIPMENT_DATA
   - DOLMAS
   - DOCMAS
3. Distribute the model to the target systems using menu navigation as:
   - Edit > Model View > Distribute
4. Generate the Partner Profiles using the menu navigation as:
   - Environment > Generate Partner Profiles

Create Document Info Record

Use the following steps to create Document Info Record:

1. Run t-code CV03N.
2. Enter the required inputs:
   - Document Type (Mandatory)
   - Document Part
   - Document Version
   - Document Number

Assigning Document Info Record to Equipment

Use the following steps to assign document Info record to Equipment:

1. Launch NWBC.
2. Select the menu role /UGI/ MDG_EAM_MENU.
   The Home screen is displayed as in the following:

   ![Home Screen Image]

3. Go to Equipment Search application and click on “New” button to create a new Change Request.

   ![Equipment Search Screen Image]
4. Enter the mandatory fields like Equipment description and Category.

![Change Request Screen](image1)

5. Go to “Document Assignment” assignment block and add the document by clicking on “Assign Existing Document” button. Provide the document that is created earlier.

![Document Assignment Screen](image2)

6. Process the CR and Approve it.
   The Equipment is created with DIR.

![Equipment Master Data](image3)

The Equipment is replicated to target system through an IDoc.
Replication of Document Info Records with Document Links

Use the following steps to replicate Document Info records with Document Links:

1. Run t-code BDA5 in the source system to replicate the Document.
2. Enter the DIR details to be replicated along with the Logical System to which DIR needs to be replicated.
3. Click F8 to replicate the DIR.
   - Document is replicated along with the link.
4. Login to the target system and verify the details using t-code CV03N.
Enable URL using Generic Object Services

The following topics are discussed in this section:

- **Prerequisites**
- **Brief Overview**
- **Configuration**
- **Sample Implementation**
- **Troubleshooting**

### Prerequisites

1. Key Mapping for the object must be configured. For more information refer document on Key Mapping.
2. Generic Object Services (GOS) must be enabled at the user level or at the system level.

### Brief Overview

Any URL created under GOS is visible from the MDG under the “Attachment List” section. The “Attachment List” section is hidden if URLs are not present in ECC.
Configuration

The following configuration is required to enable URL replication across system. Using the t-code SGOS, maintain the configuration as in the following for the service “VIEW_ATTA” to view multiple URLs of the source system at the target system. Sample implementation for the generic service is provided at the “Sample Implementation” section.

![Configuration Screenshot](image1)

Sample Implementation

The sample implementation /UGI/CL_EXAMPLE_GOS_SRV_ATTA can be used as reference.

URLs created in ECC system are not replicated in target system, but the URLs are picked up from the source system. To enable the URL to be picked from the source system the above configuration must be maintained at the target system. The sample implementation class “/UGI/CL_EXAMPLE_GOS_SRV_ATTA” must be modified in such a way that it points to the source system.

The RFC of the source system must be maintained in the variable GV_RFC as displayed in the following screen.

![Sample Implementation Screenshot](image2)

Troubleshooting

If the URL are not displayed at the target system, then use the following steps:

1. Check if the GOS related configuration is maintained.
2. Check if the RFC destination of the source system is maintained correctly as explained in the section on Sample Implementation.
3. Check the Key Mapping is maintained correctly.